Completed
We are postponing this scheduled maintenance due to unforeseen circumstances. The maintenance window will be rescheduled for next week. We apologize for any inconvenience and will provide further updates if the schedule changes.
Posted Jun 28, 2026 - 08:08 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 28, 2026 - 08:00 UTC
Scheduled
We've got maintenance planned for 28.06.2025, starting at 08:00 AM UTC for 2 hours, and the access to the Insightful dashboard might be limited during that window. However, the employee data should be collected without interruptions and synced to your dashboard after downtime.
Thank you for your patience!
Posted Jun 26, 2026 - 14:26 UTC
This scheduled maintenance affected: Backend microservices (IAM, Emails, Analytics, Realtime, Apps and sites directory, Project management, Billing, Email reports, Jobs, Installation generator, Files, Session recording, Directory, Notifications, Utils), Frontend (Frontend Application, Frontend API), Data collection and processing (Gateway, Apps and websites usage, Screenshots, Shifts, Breaks, Time on projects and tasks, Productivity, BIM, RPA, Agent, ATM, Locations, Audit, Manual Entry, Screen recording), Integrations (Trello, Jira, Monday, Data warehouse, Merge, Calendar Integration, AI Services), and Website, Google Cloud Platform Google Kubernetes Engine, Google Cloud Platform Google Cloud Storage, Elastic Cloud Elasticsearch connectivity: GCP us-east4, SendGrid API v3, Stripe API, Stripe Webhooks, Stripe Emails, Stripe JS, Intercom Medium message delivery, Intercom Small message delivery, Intercom Web Messenger, Intercom Intercom Webhooks.